gated.conf.4 (2010 09)
g
gated.conf(4) gated.conf(4)
Interfaces Statement
Interface Syntax
interfaces {
options
[ strictinterfaces ]
[ scaninterval time ]
[ aliases-nh ( primary | lowestip | keepall )]
;
interface interface_list
[ preference preference ]
[ down preference preference ]
[ passive ]
[ simplex ]
[ reject ]
[ blackhole ]
[ alias primary address ]
[ aliases-nh ( primary | lowestip | keepall )]
;
define address
[ broadcast address ]|[pointtopoint address ]
[ netmask mask ]
[ multicast ]
;
};
An interface is the connection between a router and one of its attached networks. A physical interface
may be specified by interface name, by IP address, or by domain name, (unless the network is an unnum-
bered point-to-point network.) Multiple levels of reference in the configuration language allow
identification of interfaces using wildcard, interface type name, or delete word address. Be careful with
the use of interface names as future Unix operating systems may allow more than one address per inter-
face. The interface_list is a list of one or more interface names including wildcard names (names without
a number) and names which may specify more than one interface or address, or the token all for all
interfaces.
options
Allows configuration of some global options related to interfaces. These are:
strictinterfaces
Indicates that it is a fatal error to reference an interface in the configuration file that is
not present when GateD is started and not listed in a define statement. Without this
option a warning message will be issued but GateD will continue.
scaninterval time
Specifies how often GateD scans the kernel interface list for changes. The default is every
15 seconds on most systems, and 60 seconds on systems that pass interface status
changes through the routing socket (BSD 4.4). Note that GateD will also scan the inter-
face list on receipt of a SIGUSR2.
aliases-nh ( primary | lowestip | keepall )
Specifies which address GateD will install as the next hop for interface routes when mul-
tiple addresses are assigned to an interface like the Service Guard environment. If
pri-
mary is used, the primary interface address (default) will be installed. If lowestip is
used, the address with the lowest IP address will be installed. If keepall is used, all
interface routes are kept in the kernel up to a maximum of RT_N_MULTIPATH routes.
This is a compile-time constant. This is a global parameter that may be overridden for
interfaces using the interface option.
Note: The
keepall option is mandatory when gated is being used in a Service Guard
environment.
interface interface_list
Sets interface options on the specified interfaces. An interface list is all or a list of interface
names (see warning about interface names), domain names, or numeric addresses. Options
available on this statement are:
HP-UX 11i Version 3: September 2010 − 7 − Hewlett-Packard Company 7