complex.5 (2010 09)

c
complex(5) complex(5)
(HP Integrity Server Only)
NAME
complex - complex functions and macros
SYNOPSIS
#include <complex.h>
DESCRIPTION
This file contains declarations of all the functions in the Complex Library (described in Section (3M)).
It defines the types
extended The Integrity server 80-bit double-extended type.
quad An IEEE 754-compliant, 128-bit floating-point type. On HP-UX,
quad is a
synonym for
long double.
It defines the macros
complex Expands to _Complex, a keyword designating complex types.
imaginary Expands to _Imaginary, a keyword designating imaginary types.
These macros and the names of the real types, in combination, provide designations for the complex and
imaginary types
float complex
double complex
long double complex
extended complex
quad complex
float imaginary
double imaginary
long double imaginary
extended imaginary
quad imaginary
This file also defines the macros
_Imaginary_I Expands to a constant expression of type const float imaginary, with the
value of the imaginary unit (a number whose square is -1).
_Complex_I Expands to a constant expression of type const float complex, with the
value of the imaginary unit.
I Expands to _Imaginary_I. It can be used to efficiently construct complex
expressions in the style x + y*I, where x and y are real.
This header is for Integrity servers only. To use it, compile with the default
-Ae
option. To use the types
extended complex, quad complex, extended imaginary,orquad imaginary, compile
with the -fpwidetypes option.
FILES
/usr/include/complex.h
SEE ALSO
intro(3), fenv(5), math(5).
STANDARDS CONFORMANCE
<complex.h> : ISO/IEC C99 (including Annex G, ‘‘IEC 60559-compatible complex arithmetic’’)
HP-UX 11i Version 3: September 2010 1 Hewlett-Packard Company 1

Summary of content (2 pages)